Advanced Installer Main MenuCopy link to this sectionLink to this section copied!

Warning!This article is deprecated, for the latest Advanced Installer user interface documentation see the Ribbon page.

The menu bar gives you access to all the features of Advanced Installer, some of them not available from the toolbar. It contains the following sub menus: “File”, “View”, “Installation”, “Project”, “Wizards”, “Options” and “Help”.

Main Menu

The File menuCopy link to this sectionLink to this section copied!

  • New... - allows you to create a new project. The Start Page will be displayed.
  • Open... - opens an existing project (.AIP). Also opens built installer database files (.MSIs) in MSI Quick-Edit mode.
  • Add... - adds new or existing projects to your Advanced Installer solution
  • Save - saves the current project.
  • Save As... - saves the current project under a different name.
  • Save As Template... - creates a project template starting from the current project in order to reuse it in building a different package. New UpgradeCode, ProductCode and all the components GUIDs are generated when the template is used.
  • Settings... - configure External Tools, Auto Import, Repository Manager, Repackager Şettings, Package Validation, Windows Defender Settings, Auto Updates.
  • Help... - provides central access to official product documentation, technical support channels, software licensing, update notes, and system log files
  • Contents - displays the Advanced Installer User Guide.
  • Context Help - displays a help page for the current view in your project (it is a context sensitive help).
  • Support Forums - opens in the default browser the web page of the Advanced Installer forum.
  • Purchase Now - opens the web page where you can buy an Advanced Installer license.
  • Register... - allows you to introduce the registration code you received when you bought Advanced Installer. After that a license will be downloaded and installed on your machine.
  • About... - displays general information about Advanced Installer, like version, license, etc. and checks for updates.
  • Exit - closes the application.

The Project menuCopy link to this sectionLink to this section copied!

  • Build - creates the Windows Installer package.
  • Cancel - aborts an active project build process currently in progress.
  • Run - launches the current project. If the project is not already built, this option will first build the project and then run the generated package.
  • Run in Sandbox - executes the installer within a Windows Sandbox environment for clean, isolated testing without altering your host system.
  • Run in VM - test the installation by running it in a provisioned virtual machine.
  • Run in Docker - runs the installation process inside a designated Docker container for containerized environment testing.
  • Show run log - launches the current project in logging mode. If the project is not already built, this option will first build the project and then run the generated package.
  • Debug cmd line - enables custom command-line arguments to be passed to the installer package when launching it for testing.
  • Open Output Folder - a Windows Explorer window will open at the location where the project is saved and where the MSI package will be build.
  • Options... - allows setting the project options from the Project Options Dialog.
  • Find - this dialog allows you to customize the search criteria. The search is made globally(the entire project) and it is possible to add more tables to the search.
  • Project Summary - opens an executive overview showing project statistics, configured resources, and target settings.

The View menuCopy link to this sectionLink to this section copied!

  • Status Bar - shows or hides the status bar.
  • Only Non-Empty Views - hides left pane entries for pages were nothing was modified in the project.
  • Left Pane > - opens a sub menu with two items:
    • Show - shows or hides the left pane.
    • Compact Left Pane - small icons in the left pane page menu to save screen space.
    • Legacy Project Templates - enables or disables the visibility of older project template types.
    • Status Bar - wToggles the display of the status bar at the bottom of the window, showing current application state.
  • Last Change - navigate to the last location where the project was modified. You can also use the [ Go To Last Change ] toolbar button or press the Alt + Down keyboard shortcut.
  • Back - navigate back in the project. You can also use the [ Back ] toolbar button or press the Alt + Left keyboard shortcut.
  • Next - navigate forward in the project. You can also use the [ Next ] toolbar button or press the Alt + Right keyboard shortcut.
  • Info Panes >
    • Installation - This menu contains grouped links to all available installation pages. The pages unavailable in the current project appear disabled. The currently selected page is marked with a bullet. Clicking on an item will bring up the corresponding page.
    • Output - Displays the build output pane to review log messages, compiled artifacts, and build status.
    • Issues Pane - shows the results of the ICE validation process.
    • Run Pane - toggles the execution pane to monitor and manage test runs of your installer.
    • References Pane - displays a list with the references of the item you have tried to delete.
    • Find Result Pane - displays the results found matching the imposed criteria.
    • Notes Pane - displays various notes added and is specific for the selected view.
    • Notes Pane - displays the internal notes pane where you can leave comments or documentation for the project.
    • Notifications Pane - displays a list with all the notifications that appeared while authoring the package. Also, notifications about synchronized folders will be displayed when loading the project.
    • Assistant - shows the interactive AI Assistant pane, providing guided instructions and contextual help.
    • Messages - opens the built-in message center to view product updates, release announcements, feature highlights, and technical articles from the Advanced Installer team.
    • Right Side Pane - opens a dropdown menu that allows you to select which information panels (such as Output, Issues, References, Notes, or Assistant) to dock and display on the right side of the workspace.

SettingsCopy link to this sectionLink to this section copied!

  • External Tools... - allows you to configure additional tools used during the build process through the External Tools dialog.
  • Auto Import... - allows you to configure the extensions used when importing XML and INI files.
  • Repository Manager... - manage dialogs or prerequisites in the Advanced Installer repository.
  • Repackager settings... - allows you to configure installation capture profiles for Advanced Repackager.
  • Package Validation... - allows you to configure the parameters for the ICE Validation process.
  • Auto Updates... - allows you to configure Advanced Installer's update process through the "Update Options" dialog.

The Wizard menuCopy link to this sectionLink to this section copied!

  • Convert Paths... - this wizard scans your installation project for static paths and changes them to path variables, which makes your project more easily portable. Alternatively the wizard allows you to transform project paths that already use path variables, to absolute.
  • Create Transform... - this wizard allows you to create a Windows Installer Transform file (MST).
  • Add Adobe Plug-in
  • Office Addin
  • Detect MSM - this wizard allows you to automatically replace resources (files and registry) from your project with a merge module that contanis them.
  • Import
    • Visual Studio Project... - imports a Visual Studio Project into an Advanced Installer project.
    • Visual Basic 6.0 Project: Imports legacy Visual Basic 6.0 project files (.vbp), automatically identifying necessary runtime dependencies and ActiveX controls.
    • Real Studio Project - imports project files from Real Studio (now Xojo) to quickly generate installer configurations for applications built on that platform.
    • Import MSI/MSM... - imports an MSI/MSM file into a existing Advanced Installer project.
    • Eclipse Workspace... - imports the projects from an Eclipse workspace into an existing Advanced Installer project.
    • IntelliJ IDEA Workspace... - imports the projects from an IntelliJ IDEA workspace into an existing Advanced Installer project.
    • Repackage Result File - imports the output file (.rpk) from the Advanced Installer Repackager tool to build a clean installer package from captured installation snapshots.